刚开始使用 AWS EC2 遇到的一些坑

前不久通过学校的教育邮箱申请到了亚马逊 AWS 75美元的教育资助,使用期为一年。因为是第一次使用亚马逊 AWS EC2,所以刚开始遇到了一些小坑。幸运的是,只要善用搜索引擎,这些问题都能很快得到解决。

创建实例

  1. 登陆 AWS 控制面板后,选择 "启动实例" >> "选择一个Amazon 系统映像" >> "Ubuntu Server 16.04 LTS (HVM)",免费的配置是 1核1G,接下来的安全组先默认就可以了。注意: 免费 EC2 主机只能选择默认的区域:美国西部(俄勒冈),否则会创建失败
  1. 成功启动一个实例后,我们接下来想做的自然是用 SSH 连接这个 EC2 主机。回到 AWS 控制面板,点左侧面板上的 "网络与安全" >> "密钥对" >> "创建密钥对"。输入名称后确认后会自动下载一个 .pem 结尾的私有密钥文件。我的是 muzi.pem,如下图

  1. 点左侧面板上 "实例",接着点 "操作" >> "连接",会弹出一个的窗口。它告诉我们如何连接我们的实例

SSH 连接实例

  1. 把刚才自动下载的私有密钥文件 muzi.pem 放在 /home/ 目录下。打开终端,输入
    cd home
    chmod 400 muzi.pem
  2. 接下来通过公有 DNS 连接到您的实例 ssh -i "muzi.pem" ubuntu@ec2-52-41-10-38.us-west-2.compute.amazonaws.com
  3. 第一步中私有密钥文件存放的地方随喜好自己选择。第二步直接复制弹出窗口中给出来的代码就可以了

创建安全组

  1. 通过 SSH 成功连接主机,配置好 ShadowsocksR 后发现无法正常使用,且无法 ping 通。谷歌后发现,只要各增加一个安全组就都可以了
  2. 点左侧面板上的 "网络与安全" >> "安全组" >> "创建安全组"。安全组名称和描述都填 ssr,出站规则和入站规则都填 所有 TCP,目标填 所有位置,其余默认。这样就可以顺利使用 ShadowsocksR 了
  3. 同样地,再创建一个新的安全组,安全组名称和描述都填 ping,出站规则和入站规则都填 所有 ICMP-IPv4,目标填 所有位置,其余默认。打开终端发现可以顺利 ping 通,ShadowsocksR 自带的 Ping serve 也可以返回结果了

Enjoy !


isco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2014, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained in this software are
owned by other third parties and used and distributed under
license. Certain components of this software are licensed under
the GNU General Public License (GPL) version 2.0 or the GNU
Lesser General Public License (LGPL) Version 2.1. A copy of each
such license is available at
http://www.opensource.org/licenses/gpl-2.0.php and
http://www.opensource.org/licenses/lgpl-2.1.php
LSW-APP-G7-1.CM3# show running-config

!Command: show running-config
!Time: Thu Sep 26 10:49:10 2019

version 6.0(2)U2(2)
hostname LSW-APP-G7-1.CM3

no feature telnet
feature tacacs+
feature ospf
feature bgp
feature udld
feature interface-vlan
feature lacp
feature lldp

username admin password 5 $1$STLAh8h3$ArrSaYMegDTe9PdhZLLgI/  role network-admin
username aliops password 5 $1$tB9vHnxd$SqbA2qiP5qVEJZaijXBwg/  role network-oper
ator
username aliops role network-admin
username alimonitor password 5 $1$Jfu3JB5n$P7NKrmS9xBGSKKrxYkDhB0  role network-
operator
no password strength-check

banner motd #
******************************************************************************
*  Welecome to Alibaba IDC Network! Anyone who unauthorized access!      *

*  was prohibited,please logout immediately!!! We will reserve the action at law
 right!!!     *
*                          ATTENTION!!!             *
*                    Please do a chkin after config        *
*                   Thank you for your cooperation.       *
*******************************************************************************
#

no ip domain-lookup
tacacs-server key 7 "wxwf123"
tacacs-server timeout 3
tacacs-server host 172.24.102.102
tacacs-server host 172.23.12.221
aaa group server tacacs+ TACACS+
    server 172.23.12.221
    server 172.24.102.102
    source-interface loopback1
logging event link-status default
logging level ethpm link-up error
logging level ethpm link-down error
errdisable recovery interval 30
errdisable recovery cause link-flap
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause pause-rate-limit
errdisable recovery cause inline-power
hardware profile unicast enable-host-ecmp
hardware profile portmode 64x10G

snmp-server user admin network-admin auth md5 0xa4e0ee71638b3a0a7d8a89fd820e0d12
 priv 0xa4e0ee71638b3a0a7d8a89fd820e0d12 localizedkey
snmp-server user aliops network-operator auth md5 0x891d4ddd62253cc50d7fc914cd4e
2d10 priv 0x891d4ddd62253cc50d7fc914cd4e2d10 localizedkey
snmp-server user aliops network-admin
snmp-server user alimonitor network-operator auth md5 0x75ce49d784f31802132745d9
7e9ff015 localizedkey
snmp-server context snmpv2 vrf default
snmp-server community snmppwv2 group network-operator
snmp-server community taobao_mrtg group network-operator
snmp-server community snmprwv2 group network-admin
snmp-server mib community-map snmppwv2 context snmpv2
snmp-server mib community-map snmprwv2 context snmpv2
snmp-server community snmppwv2 use-acl 99
snmp-server community taobao_mrtg use-acl 99
snmp-server community snmprwv2 use-acl 99
ntp distribute
ntp server 10.233.7.230 use-vrf default
ntp server 10.246.124.208 use-vrf default
ntp server 172.23.101.6 use-vrf default
ntp server 172.24.102.103 use-vrf default
ntp source-interface  loopback1
ntp access-group query-only denyntpquery
ntp commit
aaa authentication login default group TACACS+
aaa authentication login console local
aaa authorization config-commands default group TACACS+ local
aaa authorization commands default group TACACS+ local
aaa accounting default group TACACS+
tacacs-server directed-request

vrf context management
vlan configuration 1
vlan 1
ip prefix-list CSR2LSW seq 10 permit 0.0.0.0/0
ip prefix-list LSW2CSR seq 10 permit 42.156.190.0/23
ip prefix-list LSW2CSR seq 20 permit 42.156.192.0/23
ip prefix-list LSW2CSR seq 40 permit 10.105.14.0/24
ip prefix-list LSW2CSR-APPG20-21 seq 10 permit 42.156.190.0/23
ip prefix-list LSW2CSR-APPG20-21 seq 30 permit 42.120.228.0/25
ip prefix-list LSW2CSR-APPG20-21 seq 40 permit 42.120.228.128/25
ip prefix-list LSW2CSR-APPG20-21 seq 50 permit 42.156.226.0/25
ip prefix-list LSW2CSR-APPG20-21 seq 60 permit 42.156.226.128/25
route-map CSR2LSW permit 10
  match ip address prefix-list CSR2LSW
route-map LSW2CSR permit 10
  match ip address prefix-list LSW2CSR-APPG20-21
  set metric 50
route-map LSW2CSR permit 20
  match ip address prefix-list LSW2CSR-APPG22
  set metric 100


interface Vlan1

interface port-channel4096
  description To-LSW-APP-G7-2.CM3-po4096
  no switchport
  no negotiate auto
  ip address 10.105.14.1/30
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/1
  description LVS-APP-G20-1.CM3-T1
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.1/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.21

interface Ethernet1/2
  description LVS-APP-G20-2.CM3-T1
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.5/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.22

interface Ethernet1/3
  description LVS-APP-G20-3.CM3-T1
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.9/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.23

interface Ethernet1/4
  description LVS-APP-G20-4.CM3-T1
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.13/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.24

interface Ethernet1/5
  description LVS-APP-G20-5.CM3-T1
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.17/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.25

interface Ethernet1/6
  description LVS-APP-G20-6.CM3-T1
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.21/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.26

interface Ethernet1/7
  description LVS-APP-G20-7.CM3-T1
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.25/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.27

interface Ethernet1/8
  description LVS-APP-G20-8.CM3-T1
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.29/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.28

interface Ethernet1/9
  description LVS-APP-G21-1.CM3-T1
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.65/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.31

interface Ethernet1/10
  description LVS-APP-G21-2.CM3-T1
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.69/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.32

interface Ethernet1/11
  description LVS-APP-G21-3.CM3-T1
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.73/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.33

interface Ethernet1/12
  description LVS-APP-G21-4.CM3-T1
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.77/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.34

interface Ethernet1/13
  description LVS-APP-G21-5.CM3-T1
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.81/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.35

interface Ethernet1/14
  description LVS-APP-G21-6.CM3-T1
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.85/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.36

interface Ethernet1/15
  description LVS-APP-G21-7.CM3-T1
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.89/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.37

interface Ethernet1/16
  description LVS-APP-G21-8.CM3-T1
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.93/30
  ip ospf authentication message-digest
  ip ospf message-digest-key 1 md5 3 7d244ae7a4a9ea84
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  no ip ospf passive-interface
  ip router ospf 100 area 0.0.1.38

interface Ethernet1/17
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.129/30

interface Ethernet1/18
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.133/30

interface Ethernet1/19
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.137/30

interface Ethernet1/20
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.141/30

interface Ethernet1/21
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.145/30

interface Ethernet1/22
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.149/30

interface Ethernet1/23
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.153/30

interface Ethernet1/24
  shutdown
  no switchport
  logging event port link-status
  no ip redirects
  ip address 10.105.13.157/30

interface Ethernet1/25

interface Ethernet1/26

interface Ethernet1/27

interface Ethernet1/28

interface Ethernet1/29

interface Ethernet1/30

interface Ethernet1/31
  description CSR-ABTN-1.CM3-G15/0/6
  no switchport
  logging event port link-status
  ip address 10.105.14.193/30

interface Ethernet1/32
  description CSR-ABTN-1.CM3-G15/0/7
  no switchport
  logging event port link-status
  ip address 10.105.14.197/30

interface Ethernet1/33
  description CSR-ABTN-1.CM3-G16/0/6
  no switchport
  logging event port link-status
  ip address 10.105.14.201/30

interface Ethernet1/34
  description CSR-ABTN-1.CM3-G16/0/7
  no switchport
  logging event port link-status
  ip address 10.105.14.205/30

interface Ethernet1/35
  description CSR-ABTN-2.CM3-G15/0/6
  no switchport
  logging event port link-status
  ip address 10.105.14.209/30

interface Ethernet1/36
  description CSR-ABTN-2.CM3-G15/0/7
  no switchport
  logging event port link-status
  ip address 10.105.14.213/30

interface Ethernet1/37
  description CSR-ABTN-2.CM3-G16/0/6
  no switchport
  logging event port link-status
  ip address 10.105.14.217/30

interface Ethernet1/38
  description CSR-ABTN-2.CM3-G16/0/7
  no switchport
  logging event port link-status
  ip address 10.105.14.221/30

interface Ethernet1/39
  description Link_to_ISR-ACTN-1.CM3:GE5/0/9_Local
  no switchport
  logging event port link-status
  ip address 10.104.37.65/30
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/40
  description Link_to_ISR-ACTN-2.CM3:GE5/0/9_Local
  no switchport
  logging event port link-status
  ip address 10.104.37.69/30
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/41
  description Link_to_ISR-ACTN-3.CM3:xe-7/1/5_Local
  no switchport
  logging event port link-status
  ip address 10.104.37.73/30
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/42
  description Link_to_ISR-ACTN-4.CM3:xe-7/1/5_Local
  no switchport
  logging event port link-status
  ip address 10.104.37.77/30
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/43
  description Link_to_ISR-ACTN-1.CM3:GE5/0/10_Local
  no switchport
  logging event port link-status
  ip address 10.104.37.81/30
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/44
  description Link_to_ISR-ACTN-2.CM3:GE5/0/10_Local
  no switchport
  logging event port link-status
  ip address 10.104.37.85/30
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/45
  description Link_to_ISR-ACTN-3.CM3:xe-7/2/2_Local
  no switchport
  logging event port link-status
  ip address 10.104.37.89/30
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/46
  description Link_to_ISR-ACTN-4.CM3:xe-7/2/2_Local
  no switchport
  logging event port link-status
  ip address 10.104.37.93/30
  ip ospf dead-interval 10
  ip ospf hello-interval 3
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface Ethernet1/47
  description LSW-APP-G7-2.CM3
  no switchport
  logging event port link-status
  udld aggressive
  channel-group 4096 mode active

interface Ethernet1/48
  description LSW-APP-G7-2.CM3
  no switchport
  logging event port link-status
  udld aggressive
  channel-group 4096 mode active
interface loopback1
  ip address 10.105.12.1/32
  ip router ospf 100 area 0.0.0.0
clock timezone BJT 8 0
line console
line vty
boot kickstart bootflash:/n3000-uk9-kickstart.6.0.2.U2.2.bin
boot system bootflash:/n3000-uk9.6.0.2.U2.2.bin
router ospf 100
  area 0.0.1.21 stub no-summary
  area 0.0.1.22 stub no-summary
  area 0.0.1.23 stub no-summary
  area 0.0.1.24 stub no-summary
  area 0.0.1.25 stub no-summary
  area 0.0.1.26 stub no-summary
  area 0.0.1.27 stub no-summary
  area 0.0.1.28 stub no-summary
  area 0.0.1.21 range 10.196.80.0/24
  area 0.0.1.21 range 42.120.228.0/26
  area 0.0.1.21 range 42.120.228.64/26
  area 0.0.1.21 range 42.120.228.128/26
  area 0.0.1.21 range 42.120.228.192/26
  area 0.0.1.21 range 42.156.190.0/24
  area 0.0.1.21 range 42.156.191.0/24
  area 0.0.1.21 range 42.156.226.0/26
  area 0.0.1.21 range 42.156.226.64/26
  area 0.0.1.21 range 42.156.226.128/26
  area 0.0.1.21 range 42.156.226.192/26
  area 0.0.1.22 range 10.196.81.0/24
  area 0.0.1.22 range 42.120.228.0/26
  area 0.0.1.22 range 42.120.228.64/26
  area 0.0.1.22 range 42.120.228.128/26
  area 0.0.1.22 range 42.120.228.192/26
  area 0.0.1.22 range 42.156.190.0/24
  area 0.0.1.22 range 42.156.191.0/24
  area 0.0.1.22 range 42.156.226.0/26
  area 0.0.1.22 range 42.156.226.64/26
  area 0.0.1.22 range 42.156.226.128/26
  area 0.0.1.22 range 42.156.226.192/26
  area 0.0.1.23 range 10.196.82.0/24
  area 0.0.1.23 range 42.120.228.0/26
  area 0.0.1.23 range 42.120.228.64/26
  area 0.0.1.23 range 42.120.228.128/26
  area 0.0.1.23 range 42.120.228.192/26
  area 0.0.1.23 range 42.156.190.0/24
  area 0.0.1.23 range 42.156.191.0/24
  area 0.0.1.23 range 42.156.226.0/26
  area 0.0.1.23 range 42.156.226.64/26
  area 0.0.1.23 range 42.156.226.128/26
  area 0.0.1.23 range 42.156.226.192/26
  area 0.0.1.24 range 10.196.83.0/24
  area 0.0.1.24 range 42.120.228.0/26
  area 0.0.1.24 range 42.120.228.64/26
  area 0.0.1.24 range 42.120.228.128/26
  area 0.0.1.24 range 42.120.228.192/26
  area 0.0.1.24 range 42.156.190.0/24
  area 0.0.1.24 range 42.156.191.0/24
  area 0.0.1.24 range 42.156.226.0/26
  area 0.0.1.24 range 42.156.226.64/26
  area 0.0.1.24 range 42.156.226.128/26
  area 0.0.1.24 range 42.156.226.192/26
  area 0.0.1.25 range 10.196.84.0/24
  area 0.0.1.25 range 42.120.228.0/26
  area 0.0.1.25 range 42.120.228.64/26
  area 0.0.1.25 range 42.120.228.128/26
  area 0.0.1.25 range 42.120.228.192/26
  area 0.0.1.25 range 42.156.190.0/24
  area 0.0.1.25 range 42.156.191.0/24
  area 0.0.1.25 range 42.156.226.0/26
  area 0.0.1.25 range 42.156.226.64/26
  area 0.0.1.25 range 42.156.226.128/26
  area 0.0.1.25 range 42.156.226.192/26
  area 0.0.1.26 range 10.196.85.0/24
  area 0.0.1.26 range 42.120.228.0/26
  area 0.0.1.26 range 42.120.228.64/26
  area 0.0.1.26 range 42.120.228.128/26
  area 0.0.1.26 range 42.120.228.192/26
  area 0.0.1.26 range 42.156.190.0/24
  area 0.0.1.26 range 42.156.191.0/24
  area 0.0.1.26 range 42.156.226.0/26
  area 0.0.1.26 range 42.156.226.64/26
  area 0.0.1.26 range 42.156.226.128/26
  area 0.0.1.26 range 42.156.226.192/26
  area 0.0.1.27 range 10.196.86.0/24
  area 0.0.1.27 range 42.120.228.0/26
  area 0.0.1.27 range 42.120.228.64/26
  area 0.0.1.27 range 42.120.228.128/26
  area 0.0.1.27 range 42.120.228.192/26
  area 0.0.1.27 range 42.156.190.0/24
  area 0.0.1.27 range 42.156.191.0/24
  area 0.0.1.27 range 42.156.226.0/26
  area 0.0.1.27 range 42.156.226.64/26
  area 0.0.1.27 range 42.156.226.128/26
  area 0.0.1.27 range 42.156.226.192/26
  area 0.0.1.28 range 10.196.87.0/24
  area 0.0.1.28 range 42.120.228.0/26
  area 0.0.1.28 range 42.120.228.64/26
  area 0.0.1.28 range 42.120.228.128/26
  area 0.0.1.28 range 42.120.228.192/26
  area 0.0.1.28 range 42.156.190.0/24
  area 0.0.1.28 range 42.156.191.0/24
  area 0.0.1.28 range 42.156.226.0/26
  area 0.0.1.28 range 42.156.226.64/26
  area 0.0.1.28 range 42.156.226.128/26
  area 0.0.1.28 range 42.156.226.192/26
  area 0.0.1.21 authentication message-digest
  area 0.0.1.22 authentication message-digest
  area 0.0.1.23 authentication message-digest
  area 0.0.1.24 authentication message-digest
  area 0.0.1.25 authentication message-digest
  area 0.0.1.26 authentication message-digest
  area 0.0.1.27 authentication message-digest
  area 0.0.1.28 authentication message-digest
  auto-cost reference-bandwidth 100000
router bgp 65002
  router-id 10.105.12.1
  log-neighbor-changes
  address-family ipv4 unicast
    network 10.105.14.0/24
    network 42.120.228.0/25
    network 42.120.228.128/25
    network 42.156.190.0/23
    network 42.156.226.0/25
    network 42.156.226.128/25
    maximum-paths 8
  neighbor 10.105.12.2
    remote-as 65002
    update-source loopback1
    address-family ipv4 unicast
      next-hop-self
  neighbor 10.105.14.194
    remote-as 64901
    password 3 f0a6fcd5864c730fdf16962274e8466d
    address-family ipv4 unicast
      route-map CSR2LSW in
      route-map LSW2CSR out
      soft-reconfiguration inbound
  neighbor 10.105.14.198
    remote-as 64901
    password 3 f0a6fcd5864c730fdf16962274e8466d
    address-family ipv4 unicast
      route-map CSR2LSW in
      route-map LSW2CSR out
      soft-reconfiguration inbound
  neighbor 10.105.14.202
    remote-as 64901
    password 3 f0a6fcd5864c730fdf16962274e8466d
    address-family ipv4 unicast
      route-map CSR2LSW in
      route-map LSW2CSR out
      soft-reconfiguration inbound
  neighbor 10.105.14.206
    remote-as 64901
    password 3 f0a6fcd5864c730fdf16962274e8466d
    address-family ipv4 unicast
      route-map CSR2LSW in
      route-map LSW2CSR out
      soft-reconfiguration inbound
  neighbor 10.105.14.210
    remote-as 64901
    password 3 f0a6fcd5864c730fdf16962274e8466d
    address-family ipv4 unicast
      route-map CSR2LSW in
      route-map LSW2CSR out
      soft-reconfiguration inbound
  neighbor 10.105.14.214
    remote-as 64901
    password 3 f0a6fcd5864c730fdf16962274e8466d
    address-family ipv4 unicast
      route-map CSR2LSW in
      route-map LSW2CSR out
      soft-reconfiguration inbound
  neighbor 10.105.14.218
    remote-as 64901
    password 3 f0a6fcd5864c730fdf16962274e8466d
    address-family ipv4 unicast
      route-map CSR2LSW in
      route-map LSW2CSR out
      soft-reconfiguration inbound
  neighbor 10.105.14.222
    remote-as 64901
    password 3 f0a6fcd5864c730fdf16962274e8466d
    address-family ipv4 unicast
      route-map CSR2LSW in
      route-map LSW2CSR out
      soft-reconfiguration inbound
ip route 10.105.14.0/24 Null0 190
ip route 42.120.228.0/25 Null0 190
ip route 42.120.228.128/25 Null0 190
ip route 42.156.190.0/23 Null0 190
ip route 42.156.226.0/25 Null0 190
ip route 42.156.226.128/25 Null0 190
no ip source-route
system urpf disable
logging logfile local7 7 size 40940
logging server 172.24.102.102 7 use-vrf default
logging server 172.23.12.221 7 use-vrf default
logging source-interface loopback1
logging timestamp milliseconds

Drop solitude!